Textures from blender

Hello! I have a problem. I try to use a asset with material and texture from blender in xenko. I get the 3D model, but not more. When I use '.fbx format like this guy [Solved] 3D workflow with blender said, I get some material but not the textures. Not a big problem, set the texture again in xenko. But this isn’t working. When I use a 3D model from blender I can’t set a texture, anyway which format I use. Also in simple 3D models like a sphere, I try to set a texture and the asset disappears from place. I tried it with version 2.59, 2.69 and 2.79 from blender. I tried also autodesk 123, but this don’t work at all. Something with nullpointer exception. I tried version 1.8 and the new version of xenko. I tried dx 9 and 10 open gl 2.0 and 3.0 and the formats was '.fbx, '.blend, '.opj, and one time the other possible ones, but not with all versions. I have a windows 10 pro laptop with 965gtx.
Hopefully someone can help me with the problem.


If you are using blender don’t use the default material names. I noticed that if you leave them like “Material.001” things don’t work properly. I don’t think Xenko likes assets to have “.” in the names. Also when you import a model there are options for importing materials/skeletons make sure you check them appropriately.

I wasn’t using materials that had textures when I was playing with blender the other night so I can’t give you specific help regarding textures.

Another thing to look out for is Blender and Xenko use different coordinate system. So if you just import your model directly from blend file it will not be in the same orientation. The import process doesn’t seem to give you an option to correct this. I was going to try exporting as fbx from blender which does IIRC.

Hi, thanks for your help! Now it’s possible to import the material selections from blender into xenko. Problem with the texture is still existing.