Create New Game "UWP" shows requirements warning

I’m using an updated Visual Studio 2017 CE 15.2 with an updated Windows 10 Pro and I get what looks like a requirements warning.

What is this?
Am I missing some requirement?
Will this affect any thing down the road?


Windows build ran
UWP build failed

When you installed VS did you install the UWP workload?

Yes I do, which version of the Windows 10 SDK is needed?

I only have 15063 (Creators Edition)

When I try to build UWP Platform this is the message I get

Error: Platform UWP is not supported for execution.

You get this message if you try to run the game from the Game Studio but you can still build it (and run) from Visual Studio.

I will investigate why the build doesn’t work from within the Game Studio, but I believe it is because UWP needs a container to run and this cannot be defined from the Game Studio (emulator and such are provided by Visual Studio).

Unfortunately that’s all I can say for now since I’m not familiar with this part of the build process. It might still be possible to just make the build process work from the Game Studio but to run it you will still need Visual Studio.

1 Like

I thought the requirements used to specify the required SDK version, but I can’t seem to find it.

so at this point i’m very frustrated, while trying to get UWP to work I am back to my original problem of not being able to open or create game projects

this is the original thread post for that problem which I thought was solved

I tried the “Open in IDE” command, when Visual Studio opened it presented me with a dialog saying I was missing an earlier Win 10 SDK, unfortunately I did not write down the version, I accepted the install and continued. The project did not open.

I closed down Visual Studio and Xenko and tried to reopen my project, it would not open giving me the same message as the problem from the link above.

I tried uninstalling, cleaning and reinstalling everything for the 7th time for VS and 3rd for Xenko and I stall can not create new game projects let alone run UWP projects.

Unless you have some very obvious or simple alternatives I done fighting this.

Thanks for the help so far

I don’t know what to say to you. I can’t reproduce the same issues that you have.
On my personal machine, I only have one installation of Visual Studio 2017 Community with the following components:

  • UWP
    • Windows 10 SDK (10.0.10240.0)
  • .Net desktop development
    • .Net Framework 4 - 4.6 development tools
    • Blend for Visual Studio
    • Profiling tools
    • F# language support
    • .Net Framework 4.6.2 development tools
    • .Net Framework 4.7 development tools
  • Desktop development with C++
    • VC++ 2017 v141 toolset (x86,x64)
    • Windows 10 SDK (10.0.10240.0)
  • Mobile development with .Net
    • Xamarin Workbooks
    • F# language support
    • Universal Windows Platform tools for Xamarin

Note that I’m probably missing some components for iOS/Android like Android NDK for instance. But I don’t need them for the moment so I removed them to free some disk space.

I also don’t have any other VS installed side-by-side to prevent the conflict described in the other issue. This include not having a secondary install of MSBuild Tools for VS 2017, as I noted this can also conflict sometimes and anyway is useless if you already have VS installed.

So my point of frustration is that neither of these two versions of Visual Studio were clashing with each other. I only modified my environment to see if I could get Xenko to work, which is not something I believe I should have to do. Admittedly, I am probably in the minority here, I did not install Visual Studio just for Xenko or any other C# game development, I’m a professional .Net Architect and these are my tools of the trade. I further researched MSBuild and it is needed by 12+ other components I have installed, that I use, so removing that is not an option for me.

My other option is to get a machine dedicated for Xenko and I don’t believe I know enough about the product to merit this move. Unfortunately for now I’m going to move on, thanks for the help.

For anyone from Silicon Studio reading this, you have what looks like to be amazing product with lots of potential but at the moment besides missing some major features, which I was hoping I wouldn’t miss as I transitioned into a career of game development, there is way too much friction to getting started with this product that I have not felt with other competing products. I hope to be back when the product has matured much further along. Good Luck on your mission

I never said to remove MSBuild altogether. It is included with Visual Studio installation already, so adding an additional install of it is pointless and cause issues. We also use MSBuild to build games with Xenko it is actually a requirement.

There is obviously a path conflict issue in your setting. Try to launch the GameStudio from a MSBuild command prompt that points to the correct version. But since we are using APIs provided by Microsoft I’m not sure if it will fix it (the issue seems to be in their API and the way they deal with their registered keys).

Have an issue with UWP as well: it requires Windows SDK 10240, which is very outdated as this moment, is there any way in Xenko to actually cofigure the targeted platform to change the SDK to the newest one, so I won’t have to go through the huge csproj file to change the min and max SDK allowed to 10.0.15063?

You don’t need to edit the csproj file manually. In Visual Studio you can right-click on the project, open the project properties panel and change the target version there.

We always target the lowest API that we support so that Xenko stays compatible with most users/configurations. If you want to target other versions you can do it by editing the project properties. That said SDK 10240 is indeed pretty old and the next iteration of Xenko (2.1) will target 10.0.15063 by default.

That is also true for the portable Game assembly that targets .Net standard 1.4 by default but that you can upgrade to any later versions (including 2.0) if you feel the need. This is actually a general recommendation by the maker of .Net standard themselves: always target the lowest version that you can support.

ok thanks for the info. My problem is that my windows 10 PC did not have the 10240 sdk installed, but by right clicking the unloaded project (because of the missing requirements) I was able to edit the csproj file in VS. I could not get to properties since the project could not load, after my changes I could reload the project by right clicking it in VS and all was good, everything compiled.

I would believe that most users on Windows 10 devices do get the major windows 10 retail builds updates when they are released, and if someone wants to publish to XBox One UWP, would only work from 14393 (which will still work even though Xbox One have been updated to 15063 as well). The only exceptions might be those like myself who have windows phones that never got passed the anniversary update. But i understand your point here.

Now I need to learn how to use the XBox Live WinRT C# SDK to get some xbox live functionality (only will use what is compatible with Creators Program though, since I am not a ID@XBox member. Will read the microsoft developer pages about that for creators program, how to use XBox Live in VS.

One suggestion though: if you intend to make 15063 default, it might still be advisable to have a SDK version selector in Xenko for UWP developement. My experiences so far with trying to compile XBox Live code with that Creators SDK have not been a huge success (using Unity and VS 2017. Fell back to VS 2015 and Anniversary 14393, which will still work on a windows 10.0.15063 machine). FWIW, I had less trouble getting things to work out with Xenko at first use.

1 Like

Thanks for the input. The minimal target will still be 10240. I will keep your suggestion in mind and see what we can do.

Hello Everyone, I am sure this is ticked off as done but I had similar problems getting Xenko to run and although I followed all the instructions for VS worflows to the letter. I also had no support for Android and IOS aswell as UWP and found that VS was not installing .NET 4.6.2 SDK or Targetting pack. This might be a post that helps others that have googled this issue and land on this page.

I too have VS 2017 and Visual Studio Build Tools 2019 as I am trying to push this for investigation with the Digital Twin initiative and need to stay true to the removal of barriers for collaboration and education on a gradual scale.
Anyway hopefully the below screenshot will show the location to select the targetting pack.
VS Installer -> Installation Details (right of the screen)-> Optional -> .NET Framework 4.6.2 dev tools . I also have C++redistributable 2015-2019 instead of 2015-2017.
The following help topic is also good

1 Like

Same problem here!

Any solution?

Over a year later and I have the same issue on a new installation with VS2017 and VS 2019 both installed.